AMD and the Smurf-Rage story

First of all I want to mention that I’m a huge AMD fan! My last Intel CPU was a Pentium 120Mhz. Later I had Athlons of various generations and now a Phenom II 920 running @ 3,2 GHz. My last Nvidia graphics card was a GeForce 6800 that I killed with overclocking. Later I had ATI cards like the X850, 4850 and now an AMD 6870 with 1GB. I love my AMD system as it’s really giving a lot of bang-for-the-buck meaning that is good value for the money.

The video above shows Rage with the latest AMD 11.10 Catalyst WHQL drivers. This is now the 4th driver AMD released that is supposed to fix problems with id Software’s Rage. The last version 11.9 had problems with texture streaming that have been fixed later by AMD in the 11.10 preview 2 & 3 drivers. The first preview driver made Rage run faster but it had the texture popping shown in the video below. The 11.10 final version totally broke it and we have Smurf-like blue textures!

Nvidia had this problem too (just to be fair) but they managed to fix it in a driver update. AMD totally failed to do that and even made it worse with the blue texture bug! It even looks to me this might be some kind of revenge by AMD because id Software and Bethesda blamed AMD for the initial texture popping problem. Maybe it’s even because id Software cooperated with Intel on making Rage run on their Sandy Bridge CPU-integrated HD 3000 GPU. AMD looks bad here… and they should change that! It should be like in this commercial: left and right should be the same image. Currently with AMD and Intel/Nvidia on Rage it’s not the same picture even if the price is lower on the AMD side :/

AMD, you don’t want me to like the “AMD SUCKS” site on Facebook don’t you? It’s only one click away at http://www.facebook.com/pages/AMD-SUCKS/301628902631

***

If you want to solve this problem manually there is a community-driven solution for the blue texture problem: http://forums.bethsoft.com/index.php?/topic/1249144-ati-1110-final-drivers-fix/

***

Edit:  The Catalyst 11.11 performance driver finally fixes all the problems!

DL: http://support.amd.com/us/kbarticles/Pages/catalyst-1111b-performance.aspx

Advertisements

Leave a comment

No comments yet.

Comments RSS TrackBack Identifier URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s